Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-118245high8.6

Highcharts Dashboards: `chartConstructor` is an unchecked lookup into the Highcharts namespace

Impact

The Highcharts component uses the value of chartConstructor to select a function from the Highcharts namespace and invokes it with the component's container element and its chartOptions, without checking the value against the supported chart constructors. An attacker who controls the dashboard configuration can therefore name any other public member of that namespace; utility functions in that namespace copy the supplied options onto the container element as properties or attributes, so markup and event handlers carried in chartOptions land in the page and run in the origin of the page…

Source excerpt · OSV
Applies when

Exploitation requires that untrusted data reach the Dashboards component configuration.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

highcharts · GitHub_M

highcharts

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

< 13.1.0

unaffected

unknown

Other versions: unknown

@highcharts · GitHub_M

dashboards

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

>= 1.0.0, < 4.2.3

unaffected

unknown

Other versions: unknown

Original source description

Impact

The Highcharts component uses the value of chartConstructor to select a function from the Highcharts namespace and invokes it with the component's container element and its chartOptions, without checking the value against the supported chart constructors. An attacker who controls the dashboard configuration can therefore name any other public member of that namespace; utility functions in that namespace copy the supplied options onto the container element as properties or attributes, so markup and event handlers carried in chartOptions land in the page and run in the origin of the page hosting the dashboard. Exploitation requires that untrusted data reach the Dashboards component configuration. No user interaction is required beyond rendering the board.

Workarounds

If your board configuration comes from a source you do not fully control, paste this snippet right after importing libraries:

(function () {
    const HighchartsComponent =
        Dashboards && Dashboards.HighchartsComponent;

    if (!HighchartsComponent || !HighchartsComponent.prototype.createChart) {
        return; // HighchartsComponent not loaded
    }

    const allowedConstructors = [
        'chart',
        'stockChart',
        'mapChart',
        'ganttChart'
    ];
    const originalCreateChart = HighchartsComponent.prototype.createChart;

    HighchartsComponent.prototype.createChart = function () {
        if (allowedConstructors.indexOf(this.chartConstructor) === -1) {
            this.chartConstructor = 'chart';
        }

        return originalCreateChart.apply(this, arguments);
    };
}());

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/dashboards@4.2.2. If you load Highcharts Dashboards from a CDN, use a versioned URL, for example https://code.highcharts.com/dashboards/4.2.2/dashboards.js. For more on each installation method, see the installation guide.

Inside the record

Evidence available

Package identity
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-118245

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-79 ↗

CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

GitHub_M

Related →
Contributing organizations · 2
GitHub_M

Assigning organization

2026-10-28
CISA-ADP

Additional data publisher

2026-10-29

What changed

Follow changes
  1. CVE · CVE-2026-118245

    Observed 2026-10-29T21:32:28.068Z · upstream updated 2026-10-29T20:55:28.922Z

    Prioritization updated

    before

    []

    after

    [
      {
        "source": "CISA-ADP",
        "type": "SSVC",
        "role": "CISA Coordinator",
        "timestamp": "2026-10-29T15:36:32.905942Z",
        "decisions": [
          {
            "name": "Exploitation",
            "value": "none"
          },
          {
            "name": "Automatable",
            "value": "no"
          },
          {
            "name": "Technical Impact",
            "value": "total"
          }
        ]
      }
    ]

Large field values are marked as truncated previews. Original source snapshots remain retained.

Showing up to 50 most recent observed changes.

References

5 sources