WordPress Widget Options plugin <= 4.2.5 - Remote Code Execution (RCE) vulnerability
Impact
The WordPress Widget Options plugin, version 4.2.5 and earlier, has a code injection weakness. An author can potentially exploit this. The impact is uncertain.
Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.What to do
Update to 4.2.6 or a higher version.
Affected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
Marketing Fire · Patchstack
Widget Options
1 range
Marketing Fire · Patchstack
Widget Options
Compare with this publisher’s ranges. This does not inspect your installation.
affected
n/a → through 4.2.5
custom versions
From 4.2.6: unaffected
Other versions: unaffected
Original source description
Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-116852View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Contributing organizations · 2
Assigning organization
Additional data publisher
What changed
Follow changes- CVE · CVE-2026-116852
Observed 2026-10-30T22:47:48.680Z · upstream updated 2026-10-30T22:15:55.746Z
Prioritization updated
before
[]
after
[ { "source": "CISA-ADP", "type": "SSVC", "role": "CISA Coordinator", "timestamp": "2026-10-30T21:21:08.723566Z", "decisions": [ { "name": "Exploitation", "value": "none" }, { "name": "Automatable", "value": "no" }, { "name": "Technical Impact", "value": "total" } ] } ]
Large field values are marked as truncated previews. Original source snapshots remain retained.
Showing up to 50 most recent observed changes.