GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
CVE-2026-116688high8.1

CKEditor: Cross-site scripting (XSS) in the engine package

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.

Source excerpt · OSV

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected rangeRecorded fix
From 45.0.0 before 47.7.4Semantic versions47.7.4
From 48.0.0 before 48.5.1Semantic versions48.5.1

Version evidence: OSV · GHSA-rh54-vffm-5fvp

View original version evidence (0 explicit versions)
Affected rangeRecorded fix
From 45.0.0 before 47.7.4Semantic versions47.7.4
From 48.0.0 before 48.5.1Semantic versions48.5.1

Version evidence: OSV · GHSA-rh54-vffm-5fvp

View original version evidence (0 explicit versions)

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

ckeditor · ckeditor5

Version / rangeSource status
>= 45.0.0, < 47.7.4affected
>= 48.0.0, < 48.5.1affected
GitHub_M version evidence

Original source description

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.

The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.

Patches

The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

For more information

Email us at security@cksource.com if you have any questions or comments about this advisory.

References