CKEditor: Cross-site scripting (XSS) in the engine package
Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 29.0.0 before 47.7.4Semantic versions | 47.7.4 |
| From 48.0.0 before 48.5.1Semantic versions | 48.5.1 |
Version evidence: OSV · GHSA-v6mg-96c6-gmpq
View original version evidence (0 explicit versions)
| Affected range | Recorded fix |
|---|---|
| From 29.0.0 before 47.7.4Semantic versions | 47.7.4 |
| From 48.0.0 before 48.5.1Semantic versions | 48.5.1 |
Version evidence: OSV · GHSA-v6mg-96c6-gmpq
View original version evidence (0 explicit versions)
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
ckeditor · ckeditor5
| Version / range | Source status |
|---|---|
| >= 29.0.0, < 47.7.4 | affected |
| >= 48.0.0, < 48.5.1 | affected |
Original source description
Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.
This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.
Patches
The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).
For more information
Email us at security@cksource.com if you have any questions or comments about this advisory.
References
- Security advisory github.com/ckeditor/ckeditor5/security/advisories/GHSA-v6mg-96c6-gmpq
- Patch github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0
- Patch github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423
- Release notes github.com/ckeditor/ckeditor5/releases/tag/v47.7.4
- Release notes github.com/ckeditor/ckeditor5/releases/tag/v48.5.1
- Source reference github.com/ckeditor/ckeditor5