GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

CVE-2026-116679medium5.4

Neko: Authorization bypass in legacy WebRTC input handling

Check your stack

Summary

The imported advisory is rated medium severity. It identifies 1 affected package; whether you are affected depends on your installed version. It is not listed in the imported CISA KEV data; that does not establish that exploitation has not occurred.

Summary by cve.new · CC BY 4.0

Original source description

Impact

When legacy mode is enabled and session.implicit_hosting is enabled, the legacy WebRTC data channel incorrectly authorizes input events due to a logic error in LegacyIsHost().

As a result, an authenticated room member may be able to send mouse and keyboard input through the legacy WebRTC control channel even when controls are locked or the member would otherwise not be authorized through the modern control API.

The issue affects only the legacy WebRTC input path. The modern HTTP/WebSocket control path correctly enforces authorization checks and is not affected.

To exploit this issue, an attacker must:

  • Be authenticated as a room member.
  • Successfully establish a WebRTC connection.
  • Access a deployment using the legacy WebRTC input handler.

No unauthenticated access or privilege escalation outside the application is possible.

Patches

The issue has been fixed in v3.1.5 by correcting the authorization logic in the legacy WebRTC handler.

Users should upgrade to v3.1.5 or later. Fix: 395ca1a

Workarounds

Users who cannot immediately upgrade can mitigate the issue by one of the following:

  • Disable legacy mode if it is not required.
  • Disable implicit hosting (session.implicit_hosting=false).
  • Restrict access to trusted authenticated users.

Credits

Thanks to @KasperBuilds for responsibly disclosing this vulnerability and reaching out directly. This contribution helped strengthen the project, and the whole community benefits from it.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Semantic versions

From 0.0.0-20250401220545-fe94c999c6af before 0.0.0-20260805142851-395ca1a6f62b

Fixed in 0.0.0-20260805142851-395ca1a6f62b

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0.0.0-20250401220545-fe94c999c6af"
        },
        {
          "fixed": "0.0.0-20260805142851-395ca1a6f62b"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}

References