TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
The advisory, in context
Impact
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.
Patches
This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.
Workarounds
No official workaround available.
Fix
To avoid this vulnerability:
Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher.
Acknowledgements
Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 8.5.1 before 8.9.3
Fixed in 8.9.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.5.1"
},
{
"fixed": "8.9.3"
}
],
"type": "SEMVER"
}
],
"versions": []
}From 8.5.1 before 8.9.3
Fixed in 8.9.3
9 explicitly affected versions
8.5.1, 8.6.0, 8.7.0, 8.8.0, 8.8.1, 8.8.2, 8.9.0, 8.9.1, 8.9.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.5.1"
},
{
"fixed": "8.9.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.5.1",
"8.6.0",
"8.7.0",
"8.8.0",
"8.8.1",
"8.8.2",
"8.9.0",
"8.9.1",
"8.9.2"
]
}From 8.5.1 before 8.9.3
Fixed in 8.9.3
9 explicitly affected versions
8.5.1, 8.6.0, 8.7.0, 8.8.0, 8.8.1, 8.8.2, 8.9.0, 8.9.1, 8.9.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.5.1"
},
{
"fixed": "8.9.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.5.1",
"8.6.0",
"8.7.0",
"8.8.0",
"8.8.1",
"8.8.2",
"8.9.0",
"8.9.1",
"8.9.2"
]
}From 7.9.3 before 7.9.4
Fixed in 7.9.4
1 explicitly affected versions
7.9.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.9.3"
},
{
"fixed": "7.9.4"
}
],
"type": "SEMVER"
}
],
"versions": [
"7.9.3"
]
}From 7.9.3 before 7.9.4
Fixed in 7.9.4
1 explicitly affected versions
7.9.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.9.3"
},
{
"fixed": "7.9.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.9.3"
]
}From 7.9.3 before 7.9.4
Fixed in 7.9.4
1 explicitly affected versions
7.9.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.9.3"
},
{
"fixed": "7.9.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.9.3"
]
}References
- https://github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwm
- https://github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2
- https://github.com/tinymce/tinymce/releases/tag/8.9.3
- https://www.tiny.cloud/docs/tinymce/7/7.9.4-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/#overview
- https://nvd.nist.gov/vuln/detail/CVE-2026-116675
- https://github.com/tinymce/tinymce