Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-115415medium6.5

Secret masking bypass in the environment tool in Strands Agents Tools

Impact

Strands Agents Tools before 0.8.6 has a secret masking bypass vulnerability, potentially allowing remote actors to obtain environment variables, including cloud credentials and API keys, via a crafted prompt. The vulnerability is due to improper neutralization of input used for LLM prompting. Users should upgrade to version 0.8.6 or later.

Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

amazon · AMZN

strands-agents-tools

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

0.1.0 → before 0.8.6

custom versions

unaffected

unknown

Other versions: unaffected

Original source description

Improper neutralization of input used for LLM prompting in the environment tool in Strands Agents Tools before 0.8.6 might allow remote actors to obtain the agent host's environment variables in cleartext, including cloud credentials and API keys, via a crafted prompt that disables the tool's secret masking.

To remediate this issue, users should upgrade to version 0.8.6 or later and rotate any credentials that were present in the environment of agents that loaded the environment tool.

Inside the record

Evidence available

Package identity · not supplied
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers · not supplied

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-115415

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-1427 ↗

CWE-1427 Improper neutralization of input used for LLM prompting

AMZN

Related →

Environment requirements

These conditions apply together as specified by the publisher. A matching product name alone does not establish exposure.

AMZN · platform conditions

Any condition may hold

Any condition may hold

Vulnerable product

cpe:2.3:a:amazon:strands-agents-tools:*:*:*:*:*:*:*:*

From (inclusive): 0.1.0

Before: 0.8.6

Original applicability statements
[
  {
    "operator": "OR",
    "nodes": [
      {
        "operator": "OR",
        "negate": false,
        "cpeMatch": [
          {
            "vulnerable": true,
            "criteria": "cpe:2.3:a:amazon:strands-agents-tools:*:*:*:*:*:*:*:*",
            "versionStartIncluding": "0.1.0",
            "versionEndExcluding": "0.8.6"
          }
        ]
      }
    ]
  }
]
Contributing organizations · 1
AMZN

Assigning organization

2026-10-28

What changed

Follow changes
No substantive changes have been recorded here yet. History starts when cve.new observes a change after tracking is enabled; earlier edits are not reconstructed.

Large field values are marked as truncated previews. Original source snapshots remain retained.

References

3 sources