Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a cross-site scripting vulnerability in the password plugin.
Impact
Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a cross-site scripting vulnerability in the password plugin. Error text returned by a password driver was concatenated into the message presented to the user without HTML escaping, so a backend able to influence that text, such as the DirectAdmin API, could inject script into the Roundcube interface. Upstream fixed this in the commit “Fix XSS issue in handling of password driver error responses”, which escapes the driver message before display.
Source excerpt · mitreAffected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
Roundcube · Webmail
Other versions: unaffected
| Version / range | Source status |
|---|---|
| 1.6.0 to before 1.6.20 | affected |
| 1.7.0 to before 1.7.5 | affected |
Original source description
Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a cross-site scripting vulnerability in the password plugin. Error text returned by a password driver was concatenated into the message presented to the user without HTML escaping, so a backend able to influence that text, such as the DirectAdmin API, could inject script into the Roundcube interface. Upstream fixed this in the commit “Fix XSS issue in handling of password driver error responses”, which escapes the driver message before display.
References
- Source reference bugs.debian.org/1151279
- Patch github.com/roundcube/roundcubemail/commit/16bbca70b668e85332f23333946a764865bead94
- Security advisory roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5
- Release notes github.com/roundcube/roundcubemail/releases/tag/1.7.5
- Release notes github.com/roundcube/roundcubemail/releases/tag/1.6.20
- Patch github.com/roundcube/roundcubemail/commit/94298856ee67ff7817cc4def2adb634be91e28c7