Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-114422high7.5

Enable Media Replace 4.1.4 - 4.2.2 - Unauthenticated PHP Object Injection via Metadata Replacer

Impact

The Enable Media Replace WordPress plugin versions 4.1.4 to 4.2.2 are vulnerable to unauthenticated PHP object injection via metadata replacer. An attacker can inject a PHP object when a user with upload access performs a media replacement. This may lead to local file inclusion of existing PHP or HTML files.

Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

Unknown · WPScan

Enable Media Replace

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

4.1.4 → before 4.2.3

semver versions

unaffected

unknown

Other versions: unaffected

Original source description

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.

Inside the record

Evidence available

Package identity · not supplied
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-114422

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-502 ↗

CWE-502 Deserialization of Untrusted Data

CISA-ADP

Related →
Contributing organizations · 2
WPScan

Assigning organization

2026-10-30
CISA-ADP

Additional data publisher

2026-10-30

What changed

Follow changes
  1. CVE · CVE-2026-114422

    Observed 2026-10-30T14:52:28.000Z · upstream updated 2026-10-30T13:26:47.999Z

    Severity assessment changed

    before

    []

    after

    [
      {
        "source": "CISA-ADP",
        "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H",
        "score": 7.5
      }
    ]
    Weakness classification changed

    before

    []

    after

    [
      {
        "id": "CWE-502",
        "description": "CWE-502 Deserialization of Untrusted Data",
        "source": "CISA-ADP"
      }
    ]
    Prioritization updated

    before

    []

    after

    [
      {
        "source": "CISA-ADP",
        "type": "SSVC",
        "role": "CISA Coordinator",
        "timestamp": "2026-10-30T13:19:03.362736Z",
        "decisions": [
          {
            "name": "Exploitation",
            "value": "none"
          },
          {
            "name": "Automatable",
            "value": "no"
          },
          {
            "name": "Technical Impact",
            "value": "total"
          }
        ]
      }
    ]

Large field values are marked as truncated previews. Original source snapshots remain retained.

Showing up to 50 most recent observed changes.

References

1 sources