Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-112407high8.8

Incorrect privilege assignment in AWS CICD-toolchain-for-serverless-applications

Impact

AWS CICD-toolchain-for-serverless-applications versions 1.0.7 through 1.0.10 have an incorrect privilege assignment weakness, allowing authenticated users with push access to escalate privileges. The impact is access or modification of resources outside the application stack. Users should upgrade to version 1.0.11 or later.

Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

AWS · AMZN

CICD-toolchain-for-serverless-applications

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

1.0.7 → through 1.0.10

custom versions

unaffected

unknown

Other versions: unaffected

Original source description

Incorrect privilege assignment in the IAM policy of AWS CICD-toolchain-for-serverless-applications 1.0.7 through 1.0.10 allows remote authenticated users with push access to the application source repository to escalate privileges and access or modify resources outside the application stack in the same AWS account via application templates deployed by the toolchain pipeline.

To remediate this issue, users should upgrade existing toolchain stacks to version 1.0.11 or later.

Inside the record

Evidence available

Package identity · not supplied
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-112407

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-266 ↗

CWE-266 Incorrect privilege assignment

AMZN

Related →

Environment requirements

These conditions apply together as specified by the publisher. A matching product name alone does not establish exposure.

AMZN · platform conditions

Any condition may hold

Any condition may hold

Vulnerable product

cpe:2.3:a:aws:cicd-toolchain-for-serverless-applications:*:*:*:*:*:*:*:*

From (inclusive): 1.0.7

Through (inclusive): 1.0.10

Original applicability statements
[
  {
    "operator": "OR",
    "nodes": [
      {
        "operator": "OR",
        "negate": false,
        "cpeMatch": [
          {
            "vulnerable": true,
            "criteria": "cpe:2.3:a:aws:cicd-toolchain-for-serverless-applications:*:*:*:*:*:*:*:*",
            "versionStartIncluding": "1.0.7",
            "versionEndIncluding": "1.0.10"
          }
        ]
      }
    ]
  }
]
Contributing organizations · 2
AMZN

Assigning organization

2026-10-20
CISA-ADP

Additional data publisher

2026-10-28

What changed

Follow changes
No substantive changes have been recorded here yet. History starts when cve.new observes a change after tracking is enabled; earlier edits are not reconstructed.

Large field values are marked as truncated previews. Original source snapshots remain retained.

References

3 sources