Langflow OSS is affected by multiple vulnerabilities
Impact
IBM Langflow OSS versions 1.0.0 through 1.12.4 have an improper authentication weakness, which could allow a remote attacker to obtain sensitive information. The vulnerability is due to CWE-287 Improper Authentication. Affected versions are 1.0.0 through 1.12.4.
Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.What to do
IBM strongly recommends addressing the vulnerability now by upgrading Langflow OSS to version 1.12.5. https://pypi.org/project/langflow/1.12.5/
For Langflow OSS versions 1.0.0 - 1.12.4, follow the Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the Langflow OSS installation instructions https://docs.langflow.org/get-started-installation to install version 1.12.5 and test your flows. For deployments using MCP stdio, also apply the configuration controls in Workarounds and Mitigations.
This bulletin also discloses fixes delivered in prior releases: CVE-2026-107366 was fixed in version 1.9.0; CVE-2026-18894 was fixed in version 1.11.2; and CVE-2026-77817 was fixed in version 1.11.5. Version 1.12.5 includes these fixes.
IBM strongly recommends applying the following configuration controls to deployments using MCP stdio in addition to upgrading Langflow OSS to version 1.12.5. These controls do not replace the upgrade.
Set LANGFLOW_MCP_SERVER_INTERPRETER_HARDENING=true to reject direct shell-script execution, and set LANGFLOW_CUSTOM_COMPONENT_ADMIN_ONLY=true to block non-admin MCP stdio access. Restart the Langflow service after updating its environment configuration. These restrictions can require changes to existing MCP server launch configurations and limit which users can use MCP stdio.
For public workflows, retain the default restriction on custom components. Explicitly enabling LANGFLOW_ALLOW_PUBLIC_CUSTOM_COMPONENTS permits custom component execution and changes the default protection described for CVE-2026-18894.
For CVE-2026-77817, upgrading prevents the identified secret disclosure in new flow and project exports. Revoke or rotate any credentials exposed in previously exported files; upgrading does not remove secrets from copies already exported.
Affected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
IBM · ibm
Langflow OSS
1 range
IBM · ibm
Langflow OSS
Compare with this publisher’s ranges. This does not inspect your installation.
affected
1.0.0 → through 1.12.4
semver versions
Other versions: unknown
Product identifiers (CPE)
cpe:2.3:a:ibm:langflow_oss:1.0.0:*:*:*:*:*:*:*cpe:2.3:a:ibm:langflow_oss:1.12.4:*:*:*:*:*:*:*Original source description
IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote attacker to obtain sensitive information due to improper authentication.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-110245View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Contributing organizations · 1
Assigning organization
What changed
Follow changesLarge field values are marked as truncated previews. Original source snapshots remain retained.