Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-110190medium6.5

Langflow OSS is affected by multiple vulnerabilities

Impact

IBM Langflow OSS versions 1.0.0 through 1.12.4 are affected by a path traversal vulnerability, allowing an authenticated user to view arbitrary files on the system by sending a specially crafted URL request. The vulnerability is due to improper limitation of a pathname to a restricted directory. An attacker needs authenticated access to exploit the weakness.

Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.

What to do

IBM strongly recommends addressing the vulnerability now by upgrading Langflow OSS to version 1.12.5. https://pypi.org/project/langflow/1.12.5/

For Langflow OSS versions 1.0.0 - 1.12.4, follow the Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the Langflow OSS installation instructions https://docs.langflow.org/get-started-installation to install version 1.12.5 and test your flows. For deployments using MCP stdio, also apply the configuration controls in Workarounds and Mitigations.

This bulletin also discloses fixes delivered in prior releases: CVE-2026-107366 was fixed in version 1.9.0; CVE-2026-18894 was fixed in version 1.11.2; and CVE-2026-77817 was fixed in version 1.11.5. Version 1.12.5 includes these fixes.

ibm guidance

IBM strongly recommends applying the following configuration controls to deployments using MCP stdio in addition to upgrading Langflow OSS to version 1.12.5. These controls do not replace the upgrade.

Set LANGFLOW_MCP_SERVER_INTERPRETER_HARDENING=true to reject direct shell-script execution, and set LANGFLOW_CUSTOM_COMPONENT_ADMIN_ONLY=true to block non-admin MCP stdio access. Restart the Langflow service after updating its environment configuration. These restrictions can require changes to existing MCP server launch configurations and limit which users can use MCP stdio.

For public workflows, retain the default restriction on custom components. Explicitly enabling LANGFLOW_ALLOW_PUBLIC_CUSTOM_COMPONENTS permits custom component execution and changes the default protection described for CVE-2026-18894.

For CVE-2026-77817, upgrading prevents the identified secret disclosure in new flow and project exports. Revoke or rotate any credentials exposed in previously exported files; upgrading does not remove secrets from copies already exported.

ibm guidance

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

IBM · ibm

Langflow OSS

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

1.0.0 → through 1.12.4

semver versions

unaffected

unknown

Other versions: unknown

Product identifiers (CPE)cpe:2.3:a:ibm:langflow_oss:1.0.0:*:*:*:*:*:*:*cpe:2.3:a:ibm:langflow_oss:1.12.4:*:*:*:*:*:*:*

Original source description

IBM Langflow OSS 1.0.0 through 1.12.4 could allow an authenticated user to traverse directories on the system. An attacker could send a specially crafted URL request to view arbitrary files on the system.

Inside the record

Evidence available

Package identity · not supplied
Version evidence
Remediation guidance
Weakness classification
Additional publishers

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-110190

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-22 ↗

CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

ibm

Related →
Contributing organizations · 2
ibm

Assigning organization

2026-10-29
CISA-ADP

Additional data publisher

2026-10-29

What changed

Follow changes
  1. CVE · CVE-2026-110190

    Observed 2026-10-29T17:48:25.988Z · upstream updated 2026-10-29T17:18:06.527Z

    Prioritization updated

    before

    []

    after

    [
      {
        "source": "CISA-ADP",
        "type": "SSVC",
        "role": "CISA Coordinator",
        "timestamp": "2026-10-29T16:15:07.742328Z",
        "decisions": [
          {
            "name": "Exploitation",
            "value": "none"
          },
          {
            "name": "Automatable",
            "value": "no"
          },
          {
            "name": "Technical Impact",
            "value": "partial"
          }
        ]
      }
    ]

Large field values are marked as truncated previews. Original source snapshots remain retained.

Showing up to 50 most recent observed changes.

References

1 sources