Reachable Assertion in ntpsec
Impact
NTPsec ntpd versions 1.1.4 through 1.2.5 have a reachable assertion weakness, allowing a remote attacker to terminate the daemon via an NTS request with excess NTS Cookie Placeholder extension fields. The product is NTPsec ntpsec. Required attacker access is remote.
Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.What to do
Upgrade to version 1.2.6
Affected packages
Affected products
Vendor version evidence. Product records are separate from automatic dependency matching.
NTPsec · GitLab
ntpsec
1 range
NTPsec · GitLab
ntpsec
Compare with this publisher’s ranges. This does not inspect your installation.
affected
1.1.4 → before 1.2.6
semver versions
Other versions: unaffected
Original source description
Reachable exit in NTPsec ntpd 1.1.4 through 1.2.5 allows a remote attacker to terminate the daemon via an NTS request with excess NTS Cookie Placeholder extension fields.
Inside the record
Evidence available
Describes the evidence in this view, not whether the product is safe.
Original records
CVE-2026-102483View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.
cve.new JSON →Underlying weaknesses
The source’s classification of what caused the vulnerability.
Contributing organizations · 2
Assigning organization
Additional data publisher
What changed
Follow changesLarge field values are marked as truncated previews. Original source snapshots remain retained.