Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Skip to content
Check your stack
CVE-2026-101897medium5.1

Angular DevTools (Local DoS)

Impact

Angular DevTools versions 1.20.0 to 1.21.1 have a weakness that allows untrusted web pages to send messages, potentially causing a local denial of service. An attacker with access to a valid tabId can trigger Chrome DevTools Protocol breakpoints. This issue is fixed in version 1.21.1.

Summarized by @cf/meta/llama-3.3-70b-instruct-fp8-fast. Verify details against the original sources.

Affected packages

This source has no supported package-version data for matching. You can read the advisory here, but this record alone cannot power a dependency check.

Affected products

Vendor version evidence. Product records are separate from automatic dependency matching.

angular · GitHub_M

angular

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

< 22.2.0-rc.0

unaffected

unknown

Other versions: unknown

angular · GitHub_M

DevTools

1 range

Compare with this publisher’s ranges. This does not inspect your installation.

affected

>= 1.20.0, < 1.21.1

unaffected

unknown

Other versions: unknown

Original source description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. From 1.20.0 until 1.21.1, the Angular DevTools background service worker accepts chrome.runtime.sendMessage runtime messages from untrusted web pages or third-party content scripts without adequately verifying the message source. An untrusted sender that obtains a valid randomized victim tabId can direct the extension to use chrome.debugger to attach to another browser tab and trigger Chrome DevTools Protocol breakpoints. This can display the debugging banner, pause JavaScript execution, and prevent interaction with the target tab, but it does not provide remote code execution, privilege escalation, or cross-origin access to memory or credentials. This issue is fixed in version 1.21.1.

Inside the record

Evidence available

Package identity · not supplied
Version evidence
Remediation guidance · not supplied
Weakness classification
Additional publishers

Describes the evidence in this view, not whether the product is safe.

Original records

CVE-2026-101897

View the latest unmodified CVE JSON from the official source. It may be newer than this imported page.

cve.new JSON →

Underlying weaknesses

The source’s classification of what caused the vulnerability.

CWE-346 ↗

CWE-346: Origin Validation Error

GitHub_M

Related →
CWE-441 ↗

CWE-441: Unintended Proxy or Intermediary ('Confused Deputy')

GitHub_M

Related →
CWE-940 ↗

CWE-940: Improper Verification of Source of a Communication Channel

GitHub_M

Related →
Contributing organizations · 2
GitHub_M

Assigning organization

2026-10-14
CISA-ADP

Additional data publisher

2026-10-29

What changed

Follow changes
No substantive changes have been recorded here yet. History starts when cve.new observes a change after tracking is enabled; earlier edits are not reconstructed.

Large field values are marked as truncated previews. Original source snapshots remain retained.

References

5 sources